In breve
- CVE-2026-6011 è una vulnerabilità ALTO (CVSS 8.1) che riguarda openclaw (openclaw), openclaw.
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.42%, superiore al 36.4% delle vulnerabilità.
- Correzione: aggiornare a 2026.1.29 o successiva.
| Package | Affected versions | Patched versions |
|---|
| openclaw | < 2026.1.29
| 2026.1.29
|
| openclaw npm | < 2026.1.29
| 2026.1.29
|
Description
A weakness has been identified in OpenClaw up to 2026.1.26. Affected by this issue is some unknown functionality of the file src/agents/tools/web-fetch.ts of the component assertPublicHostname Handler. Executing a manipulation can lead to server-side request forgery. The attack can be executed remotely. This attack is characterized by high complexity. The exploitation is known to be difficult. The exploit has been made available to the public and could be used for attacks. Upgrading to version 2026.1.29 can resolve this issue. This patch is called b623557a2ec7e271bda003eb3ac33fbb2e218505. Upgrading the affected component is advised.
NVD description
A weakness has been identified in OpenClaw up to 2026.1.26. Affected by this issue is some unknown functionality of the file src/agents/tools/web-fetch.ts of the component assertPublicHostname Handler. Executing a manipulation can lead to server-side request forgery. The attack can be executed remotely. This attack is characterized by high complexity. The exploitation is known to be difficult. The exploit has been made available to the public and could be used for attacks. Upgrading to version 2026.1.29 can resolve this issue. This patch is called b623557a2ec7e271bda003eb3ac33fbb2e218505. Upgrading the affected component is advised.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free