| Package | Affected versions | Patched versions |
|---|---|---|
| cxf | ≥ 4.0.0, < 4.1.8≥ 4.2.0, < 4.2.3< 3.6.12 | 4.1.84.2.33.6.12 |
An incomplete fix for CVE-2026-50645 means that it is still possible to perform a denial of service attack on Apache CXF by sending a message with many attachment headers. Users are recommended to upgrade to versions 4.2.3 or 4.1.8 or 3.6.12, which fix this issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free