| Package | Affected versions | Patched versions |
|---|---|---|
| cxf | ≥ 4.0.0, < 4.1.8≥ 4.2.0, < 4.2.3< 3.6.12 | 4.1.84.2.33.6.12 |
Apache CXF reads a top-level WSDL through its hardened StaxUtils path, which disables XML DTDs and external entities. However, any <wsdl:import> or <xsd:import> referenced from that top-level WSDL is handed off to WSDL4J, which does not disable DOCTYPE declarations or external entities. As a result, the protections applied to the top-level document do not extend to imported documents, leaving imported WSDL/XSD content vulnerable to XML External Entity (XXE) attacks. Users are recommended to upgrade to versions 4.2.3 or 4.1.8 or 3.6.12, which fix this issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free