| Package | Affected versions | Patched versions |
|---|---|---|
| rabbitmq server | ≥ 3.13.0, < 3.13.15≥ 4.0.0, < 4.0.20≥ 4.1.0, < 4.1.11≥ 4.2.0, < 4.2.6 | 3.13.154.0.204.1.114.2.6 |
RabbitMQ is a messaging and streaming broker. From 3.13.0 until 3.13.15, 4.0.20, 4.1.11, and 4.2.6, mechanisms/1 applied list_to_atom/1 to every colon-delimited token in an attacker-controlled auth_mechanism value, permanently consuming Erlang VM atoms and allowing the node to be crashed with a large request. Exploitation requires the Shovel or Federation plugin to be in use, and setting auth_mechanism requires the policymaker tag. This issue is fixed in versions 3.13.15, 4.0.20, 4.1.11, and 4.2.6.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free