| Package | Affected versions | Patched versions |
|---|---|---|
| dos | = 4.9.0≥ 4.3.0, ≤ 4.7.0 | |
| nginx gateway fabric | ≥ 1.3.0, ≤ 1.6.2≥ 2.0.0, < 2.6.2 | 2.6.2 |
| nginx ingress controller | ≥ 3.5.0, ≤ 3.7.2≥ 4.0.0, ≤ 4.0.1≥ 5.0.0, < 5.4.3 | 5.4.3 |
| nginx instance manager | ≥ 2.17.0, < 2.22.1 | 2.22.1 |
| nginx open source | = 1.31.0≥ 0.1.17, ≤ 0.9.7≥ 1.0.0, < 1.30.2 | 1.30.2 |
| nginx plus | = 37.0.0.1= r32= r36≥ r33, < r36 | r36 |
| waf | ≥ 4.10.0, ≤ 4.16.0≥ 5.2.0, ≤ 5.8.0≥ 5.9.0, ≤ 5.13.0 | |
| update infrastructure | ≥ 5.0, < 5.2 | 5.2 |
NGINX Plus and NGINX Open Source have a vulnerability in the ngx_http_rewrite_module module. This vulnerability exists when a rewrite directive uses a regex pattern with distinct, overlapping Perl-Compatible Regular Expression (PCRE) captures (for example, ^/((.*))$) and a replacement string that references multiple such captures (for example, $1$2) in a redirect or arguments context. An unauthenticated attacker along with conditions beyond their control can exploit this vulnerability by sending crafted HTTP requests. This may cause a heap buffer overflow in the NGINX worker process leading to a restart. Additionally, attackers can execute code on systems with Address Space Layout Randomization (ASLR) disabled or when the attacker can bypass ASLR. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free