In breve
- GHSA-xxx9-3xcr-gjj3 è una vulnerabilità MEDIO (CVSS 6.5) che riguarda nokogiri.
- Correzione: aggiornare a 1.13.4 o successiva.
| Package | Affected versions | Patched versions |
|---|
| nokogiri RubyGems | < 1.13.4
| 1.13.4
|
Description
Summary
Nokogiri v1.13.4 updates the vendored xerces:xercesImpl from 2.12.0 to 2.12.2, which addresses CVE-2022-23437. That CVE is scored as CVSS 6.5 "Medium" on the NVD record.
Please note that this advisory only applies to the JRuby implementation of Nokogiri < 1.13.4.
Mitigation
Upgrade to Nokogiri >= v1.13.4.
Impact
- Severity: Medium
- Type: CWE-91 XML Injection (aka Blind XPath Injection)
- Description: There's a vulnerability within the Apache Xerces Java (XercesJ) XML parser when handling specially crafted XML document payloads. This causes, the XercesJ XML parser to wait in an infinite loop, which may sometimes consume system resources for prolonged duration. This vulnerability is present within XercesJ version 2.12.1 and the previous versions.
- See also: https://github.com/advisories/GHSA-h65f-jvqw-m9fj
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free