요약
- CVE-2013-6393은(는) libyaml (pyyaml), openstack (redhat), libyaml에 영향을 주는 보통 (CVSS 6.8) 취약점입니다.
- 향후 30일 내 악용 확률(EPSS): 7.4%, 전체 취약점의 94.4%보다 높음.
- 조치: 0.2.3 이상으로 업데이트하세요.
| Package | Affected versions | Patched versions |
|---|
| libyaml | = 0.0.1= 0.1.1= 0.1.2= 0.1.3≤ 0.1.4
| No fix yet |
| openstack | = 3.0= 4.0
| No fix yet |
| libyaml npm | < 0.2.3
| 0.2.3
|
Description
Versions 0.2.2 and earlier depend on native libyaml version 0.1.5 or earlier. As such, they are affected by a heap-based buffer overflow vulnerability that may result in a crash or arbitrary code execution when parsing YAML tags.
Recommendation
- Update to version 0.2.3 that includes a version of LibYAML that contains a fix for this issue.
NVD description
The yaml_parser_scan_tag_uri function in scanner.c in LibYAML before 0.1.5 performs an incorrect cast, which allows remote attackers to cause a denial of service (application crash) and possibly execute arbitrary code via crafted tags in a YAML document, which triggers a heap-based buffer overflow.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free