요약
- CVE-2016-10532은(는) console-io (console-io project), console-io에 영향을 주는 심각 (CVSS 9.8) 취약점입니다.
- 향후 30일 내 악용 확률(EPSS): 2.3%, 전체 취약점의 83.6%보다 높음.
- 조치: 2.3.0 이상으로 업데이트하세요.
Description
Affected versions of the console-io package do not configure the underlying websocket library to require authentication, resulting in an authentication bypass vulnerability. As console-io allows terminal access on the server via a web page, an authentication bypass is essentially remote code execution.
Recommendation
Update to version 2.3.0 or later.
NVD description
console-io is a module that allows users to implement a web console in their application. A malicious user could bypass the authentication and execute any command that the user who is running the console-io application 2.2.13 and earlier is able to run. This means that if console-io was running from root, the attacker would have full access to the system. This vulnerability exists because the console-io application does not configure socket.io to require authentication, which allows a malicious user to connect via a websocket to send commands and receive the response.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free