요약
- CVE-2016-10554은(는) sequelize (sequelizejs), sequelize에 영향을 주는 심각 (CVSS 9.8) 취약점입니다.
- 향후 30일 내 악용 확률(EPSS): 1.9%, 전체 취약점의 79.5%보다 높음.
- 조치: 1.7.0 이상으로 업데이트하세요.
| Package | Affected versions | Patched versions |
|---|
| sequelize | = 1.7.0≤ 1.6.0
| No fix yet |
| sequelize npm | < 1.7.0
| 1.7.0
|
Description
Affected versions of sequelize use MySQL's backslash-based escape syntax when connecting to SQLite, despite the fact that SQLite uses PostgreSQL's escape syntax, which can result in a SQL Injection vulnerability.
Recommendation
Update to version 1.7.0-alpha3 or later.
NVD description
sequelize is an Object-relational mapping, or a middleman to convert things from Postgres, MySQL, MariaDB, SQLite and Microsoft SQL Server into usable data for NodeJS. Before version 1.7.0-alpha3, sequelize defaulted SQLite to use MySQL backslash escaping, even though SQLite uses Postgres escaping.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free