| Package | Affected versions | Patched versions |
|---|---|---|
| hawk | = 3.1.2= 4.1.0 | |
| hawk | ≥ 4.0.0, < 4.1.1< 3.1.3 | 4.1.13.1.3 |
Versions of hawk prior to 3.1.3, or 4.x prior to 4.1.1 are affected by a regular expression denial of service vulnerability related to excessively long headers and URI's.
Update to hawk version 4.1.1 or later.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free