요약
- CVE-2017-16013은(는) hapi (hapijs), hapi에 영향을 주는 높음 (CVSS 7.5) 취약점입니다.
- 향후 30일 내 악용 확률(EPSS): 1.6%, 전체 취약점의 75.2%보다 높음.
- 조치: 16.1.1 이상으로 업데이트하세요.
| Package | Affected versions | Patched versions |
|---|
| hapi | ≥ 15.0.0, ≤ 16.1.0
| No fix yet |
| hapi npm | ≥ 15.0.0, < 16.1.1
| 16.1.1
|
Description
Affected versions of hapi will crash or lock the event loop when a malformed accept-encoding header is recieved.
Recommendation
Update to version 16.1.1 or later.
NVD description
hapi is a web and services application framework. When hapi >= 15.0.0 <= 16.1.0 encounters a malformed `accept-encoding` header an uncaught exception is thrown. This may cause hapi to crash or to hang the client connection until the timeout period is reached.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free