요약
- CVE-2017-16021은(는) uri-js (garycourt), uri-js에 영향을 주는 보통 (CVSS 6.5) 취약점입니다.
- 향후 30일 내 악용 확률(EPSS): 1.3%, 전체 취약점의 71.1%보다 높음.
- 조치: 3.0.0 이상으로 업데이트하세요.
| Package | Affected versions | Patched versions |
|---|
| uri-js | ≤ 2.1.1
| No fix yet |
| uri-js npm | < 3.0.0
| 3.0.0
|
Description
Affected versions of uri-js is susceptible to a regular expression denial of service vulnerability when user input is sent to the .parse() method.
Recommendation
Update to v3.0.0 or later.
NVD description
uri-js is a module that tries to fully implement RFC 3986. One of these features is validating whether or not a supplied URL is valid or not. To do this, uri-js uses a regular expression, This regular expression is vulnerable to redos. This causes the program to hang and the CPU to idle at 100% usage while uri-js is trying to validate if the supplied URL is valid or not. To check if you're vulnerable, look for a call to `require("uri-js").parse()` where a user is able to send their own input. This affects uri-js 2.1.1 and earlier.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free