요약
- CVE-2017-16023은(는) decamelize (decamelize project), decamelize에 영향을 주는 높음 (CVSS 7.5) 취약점입니다.
- 향후 30일 내 악용 확률(EPSS): 1.4%, 전체 취약점의 73.2%보다 높음.
- 조치: 1.1.2 이상으로 업데이트하세요.
| Package | Affected versions | Patched versions |
|---|
| decamelize | = 1.1.0= 1.1.1
| No fix yet |
| decamelize npm | ≥ 1.1.0, < 1.1.2
| 1.1.2
|
Description
Affected versions of decamelize are susceptible to a denial of service vulnerability when user input is passed directly into decamelize.
Recommendation
Update to version 1.1.2 or later.
NVD description
Decamelize is used to convert a dash/dot/underscore/space separated string to camelCase. Decamelize 1.1.0 through 1.1.1 uses regular expressions to evaluate a string and takes unescaped separator values, which can be used to create a denial of service attack.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free