요약
- CVE-2017-16029은(는) hostr (hostr project), hostr에 영향을 주는 높음 (CVSS 7.5) 취약점입니다.
- 향후 30일 내 악용 확률(EPSS): 1.8%, 전체 취약점의 78.6%보다 높음.
- 조치: 2.3.6 이상으로 업데이트하세요.
| Package | Affected versions | Patched versions |
|---|
| hostr | ≤ 2.3.5
| No fix yet |
| hostr npm | < 2.3.6
| 2.3.6
|
Description
Affected versions of hostr are vulnerable to directory traversal which allows attackers to read files outside the current directory by sending ../ in the url path for GET requests.
Recommendation
Upgrade to version 2.3.6 or later.
NVD description
hostr is a simple web server that serves up the contents of the current directory. There is a directory traversal vulnerability in hostr 2.3.5 and earlier that allows an attacker to read files outside the current directory by sending `../` in the url path for GET requests.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free