| Package | Affected versions | Patched versions |
|---|---|---|
| f2e-server | ≤ 1.12.11 | |
| f2e-server | < 1.12.12 | 1.12.12 |
Affected versions of f2e-server resolve relative file paths, resulting in a directory traversal vulnerability. A malicious actor can use this vulnerability to access files outside of the intended directory root, which may result in the disclosure of private files on the vulnerable system.
Example request:
GET /../../../../../../../../../../etc/passwd HTTP/1.1
host:foo
Update to version 1.12.12 or later.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free