요약
- CVE-2017-16111은(는) content (content project), content에 영향을 주는 높음 (CVSS 7.5) 취약점입니다.
- 향후 30일 내 악용 확률(EPSS): 1.1%, 전체 취약점의 65.9%보다 높음.
- 조치: 3.0.7 이상으로 업데이트하세요.
| Package | Affected versions | Patched versions |
|---|
| content | ≤ 3.0.5
| No fix yet |
| content npm | < 3.0.7
| 3.0.7
|
Description
Affected versions of content are vulnerable to a regular expression denial of service when parsing malicious Content-Type and Content-Disposition headers.
Recommendation
Update to version 3.0.6 or later.
NVD description
The content module is a module to parse HTTP Content-* headers. It is used by the hapijs framework to provide this functionality. The module is vulnerable to regular expression denial of service when passed a specifically crafted Content-Type or Content-Disposition header.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free