요약
- CVE-2017-16118은(는) forwarded (forwarded project), forwarded에 영향을 주는 높음 (CVSS 7.5) 취약점입니다.
- 향후 30일 내 악용 확률(EPSS): 1.9%, 전체 취약점의 79.3%보다 높음.
- 조치: 0.1.2 이상으로 업데이트하세요.
Description
Affected versions of forwarded are vulnerable to regular expression denial of service when parsing specially crafted user input.
Recommendation
Update to version 0.1.2 or later
NVD description
The forwarded module is used by the Express.js framework to handle the X-Forwarded-For header. It is vulnerable to a regular expression denial of service when it's passed specially crafted input to parse. This causes the event loop to be blocked causing a denial of service condition.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free