| Package | Affected versions | Patched versions |
|---|---|---|
| debug | ≥ 2.0.0, < 2.6.9≥ 3.0.0, < 3.1.0 | 2.6.93.1.0 |
| debug | ≥ 3.0.0, < 3.1.0≥ 3.2.0, < 3.2.7≥ 4.0.0, < 4.3.1< 2.6.9 | 3.1.03.2.74.3.12.6.9 |
Affected versions of debug are vulnerable to regular expression denial of service when untrusted user input is passed into the o formatter.
As it takes 50,000 characters to block the event loop for 2 seconds, this issue is a low severity issue.
This was later re-introduced in version v3.2.0, and then repatched in versions 3.2.7 and 4.3.1.
Version 2.x.x: Update to version 2.6.9 or later. Version 3.1.x: Update to version 3.1.0 or later. Version 3.2.x: Update to version 3.2.7 or later. Version 4.x.x: Update to version 4.3.1 or later.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free