| Package | Affected versions | Patched versions |
|---|---|---|
| converse.js | = 0.10.0= 0.10.1= 0.8.0= 0.8.1= 0.8.2= 0.8.3= 0.8.4= 0.8.5= 0.8.6= 0.9.0= 0.9.1= 0.9.2= 0.9.3= 0.9.4= 0.9.5= 0.9.6= 1.0.0= 1.0.1= 1.0.2= 1.0.3= 1.0.4= 1.0.5= 1.0.6= 2.0.0= 2.0.1= 2.0.2= 2.0.3= 2.0.4 | |
| converse.js | ≥ 2.0.0, < 2.0.5< 1.0.7 | 2.0.51.0.7 |
Versions of converse.js prior to 1.0.7 for 1.x or 2.0.5 for 2.x are vulnerable to User Impersonation. The package provides an incorrect implementation of XEP-0280: Message Carbons that allows a remote attacker to impersonate any user, including contacts, in the vulnerable application's display. This allows for various kinds of social engineering attacks.
If you're using converse.js 1.x, upgrade to 1.0.7 or later.
If you're using converse.js 2.x, upgrade to 2.0.5 or later.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free