| Package | Affected versions | Patched versions |
|---|---|---|
| cfscrape | ≥ 1.6.6, < 1.8.0 | 1.8.0 |
| cloudflare-scrape | = 1.6.6= 1.6.7= 1.6.8= 1.7.0= 1.7.1 |
An issue was discovered in cloudflare-scrape 1.6.6 through 1.7.1. A malicious website owner could craft a page that executes arbitrary Python code against any cfscrape user who scrapes that website. This is fixed in 1.8.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free