| Package | Affected versions | Patched versions |
|---|---|---|
| cryptiles | ≥ 4.1.0, < 4.1.2< 3.1.3 | 4.1.23.1.3 |
| cryptiles | ≥ 3.1.0, < 3.1.3≥ 4.0.0, < 4.1.2 | 3.1.34.1.2 |
Versions of cryptiles prior to 4.1.2 are vulnerable to Insufficient Entropy. The randomDigits() method does not provide sufficient entropy and its generates digits that are not evenly distributed.
Upgrade to version 4.1.2. The package is deprecated and has been moved to @hapi/cryptiles and it is strongly recommended to use the maintained package.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free