요약
- CVE-2018-1002203은(는) unzipper (unzipper project), unzipper에 영향을 주는 보통 (CVSS 5.5) 취약점입니다.
- 향후 30일 내 악용 확률(EPSS): 10.6%, 전체 취약점의 95.8%보다 높음.
- 조치: 0.8.13 이상으로 업데이트하세요.
| Package | Affected versions | Patched versions |
|---|
| unzipper | < 0.8.13
| 0.8.13
|
| unzipper npm | < 0.8.13
| 0.8.13
|
Description
Versions of unzipper before 0.8.13 are vulnerable to arbitrary file write when used to extract a specifically crafted archive that contains path traversal filenames (../../file.txt for example).
Recommendation
Update to version 0.3.18 or later.
NVD description
unzipper npm library before 0.8.13 is vulnerable to directory traversal, allowing attackers to write to arbitrary files via a ../ (dot dot slash) in a Zip archive entry that is mishandled during extraction. This vulnerability is also known as 'Zip-Slip'.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free