요약
- CVE-2018-1002204은(는) adm-zip (adm-zip project), adm-zip에 영향을 주는 보통 (CVSS 5.5) 취약점입니다.
- 향후 30일 내 악용 확률(EPSS): 13.5%, 전체 취약점의 96.4%보다 높음.
- 조치: 0.4.9, 0.4.11 이상으로 업데이트하세요.
| Package | Affected versions | Patched versions |
|---|
| adm-zip | < 0.4.9
| 0.4.9
|
| adm-zip npm | < 0.4.11
| 0.4.11
|
Description
Versions of adm-zip before 0.4.9 are vulnerable to arbitrary file write when used to extract a specifically crafted archive that contains path traversal filenames (../../file.txt for example).
Recommendation
Update to version 0.4.9 or later.
NVD description
adm-zip npm library before 0.4.9 is vulnerable to directory traversal, allowing attackers to write to arbitrary files via a ../ (dot dot slash) in a Zip archive entry that is mishandled during extraction. This vulnerability is also known as 'Zip-Slip'.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free