| Package | Affected versions | Patched versions |
|---|---|---|
| org.apache.kafka:kafka | ≥ 0.11.0.0, < 2.1.1 | 2.1.1 |
| kafka | ≥ 0.11.0.0, ≤ 2.1.0 |
In Apache Kafka versions between 0.11.0.0 and 2.1.0, it is possible to manually craft a Produce request which bypasses transaction/idempotent ACL validation. Only authenticated clients with Write permission on the respective topics are able to exploit this vulnerability. Users should upgrade to 2.1.1 or later where this vulnerability has been fixed.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free