요약
- CVE-2018-3752은(는) merge-options (merge-options project), merge-options에 영향을 주는 심각 (CVSS 9.8) 취약점입니다.
- 향후 30일 내 악용 확률(EPSS): 1.4%, 전체 취약점의 73.1%보다 높음.
- 조치: 1.0.1 이상으로 업데이트하세요.
Description
All versions of merge-options are vulnerable to Prototype Pollution
Recommendation
Update to version 1.0.1 or greater.
NVD description
The utilities function in all versions <= 1.0.0 of the merge-options node module can be tricked into modifying the prototype of Object when the attacker can control part of the structure passed to this function. This can let an attacker add or modify existing properties that will exist on all objects.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free