요약
- CVE-2018-7651은(는) ssri (ssri project), ssri에 영향을 주는 보통 (CVSS 5.9) 취약점입니다.
- 향후 30일 내 악용 확률(EPSS): 1.7%, 전체 취약점의 77.4%보다 높음.
- 조치: 5.2.2 이상으로 업데이트하세요.
| Package | Affected versions | Patched versions |
|---|
| ssri | < 5.2.2
| 5.2.2
|
| ssri npm | < 5.2.2
| 5.2.2
|
Description
Version of ssri prior to 5.2.2 are vulnerable to regular expression denial of service (ReDoS) when using strict mode.
Recommendation
Update to version 5.2.2 or later.
NVD description
index.js in the ssri module before 5.2.2 for Node.js is prone to a regular expression denial of service vulnerability in strict mode functionality via a long base64 hash string.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free