요약
- CVE-2019-5421은(는) devise, devise (plataformatec)에 영향을 주는 심각 (CVSS 9.8) 취약점입니다.
- 향후 30일 내 악용 확률(EPSS): 1.6%, 전체 취약점의 75.2%보다 높음.
- 조치: 4.6.0 이상으로 업데이트하세요.
| Package | Affected versions | Patched versions |
|---|
| devise RubyGems | < 4.6.0
| 4.6.0
|
| devise | ≤ 4.5.0
| No fix yet |
Description
Devise ruby gem before 4.6.0 when the lockable module is used is vulnerable to a time-of-check time-of-use (TOCTOU) race condition due to increment_failed_attempts within the Devise::Models::Lockable class not being concurrency safe.
NVD description
Plataformatec Devise version 4.5.0 and earlier, using the lockable module contains a CWE-367 vulnerability in The `Devise::Models::Lockable` class, more specifically at the `#increment_failed_attempts` method. File location: lib/devise/models/lockable.rb that can result in Multiple concurrent requests can prevent an attacker from being blocked on brute force attacks. This attack appear to be exploitable via Network connectivity - brute force attacks. This vulnerability appears to have been fixed in 4.6.0 and later.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free