| Package | Affected versions | Patched versions |
|---|---|---|
| spree_api | ≥ 3.7.0, < 3.7.13≥ 4.0.0, < 4.0.5≥ 4.1.0, < 4.1.12 | 3.7.134.0.54.1.12 |
| spree | ≥ 3.7.0, < 3.7.13≥ 4.0.0, < 4.0.5≥ 4.1.0, < 4.1.12 | 3.7.134.0.54.1.12 |
The perpetrator could query the API v2 Order Status endpoint with an empty string passed as an Order token
Please upgrade to 3.7.11, 4.0.4, or 4.1.11 depending on your used Spree version. Users of Spree < 3.7 are not affected.
Pull request with a fix and in-depth explanation - https://github.com/spree/spree/pull/10573
If you have any questions or comments about this advisory:
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free