요약
- CVE-2020-36649은(는) papaparse (papaparse), papaparse에 영향을 주는 높음 (CVSS 7.5) 취약점입니다.
- 향후 30일 내 악용 확률(EPSS): 1.4%, 전체 취약점의 73.1%보다 높음.
- 조치: 5.2.0 이상으로 업데이트하세요.
| Package | Affected versions | Patched versions |
|---|
| papaparse | ≥ 5.1.0, < 5.2.0
| 5.2.0
|
| papaparse npm | < 5.2.0
| 5.2.0
|
Description
Versions of papaparse prior to 5.2.0 are vulnerable to Regular Expression Denial of Service (ReDos). The parse function contains a malformed regular expression that takes exponentially longer to process non-numerical inputs. This allows attackers to stall systems and lead to Denial of Service.
Recommendation
Upgrade to version 5.2.0 or later.
NVD description
A vulnerability was found in mholt PapaParse up to 5.1.x. It has been classified as problematic. Affected is an unknown function of the file papaparse.js. The manipulation leads to inefficient regular expression complexity. Upgrading to version 5.2.0 is able to address this issue. The name of the patch is 235a12758cd77266d2e98fd715f53536b34ad621. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-218004.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free