요약
- CVE-2021-21366은(는) xmldom (xmldom project), xmldom에 영향을 주는 보통 (CVSS 4.3) 취약점입니다.
- 향후 30일 내 악용 확률(EPSS): 1.3%, 전체 취약점의 71.4%보다 높음.
- 조치: 0.5.0 이상으로 업데이트하세요.
| Package | Affected versions | Patched versions |
|---|
| xmldom | < 0.5.0
| 0.5.0
|
| xmldom npm | < 0.5.0
| 0.5.0
|
Description
Impact
xmldom versions 0.4.0 and older do not correctly preserve system identifiers, FPIs or namespaces when repeatedly parsing and serializing maliciously crafted documents.
This may lead to unexpected syntactic changes during XML processing in some downstream applications.
Patches
Update to 0.5.0 (once it is released)
Workarounds
Downstream applications can validate the input and reject the maliciously crafted documents.
References
Similar to this one reported on the Go standard library:
For more information
If you have any questions or comments about this advisory:
- Open an issue in
xmldom/xmldom
- Email us: send an email to all addresses that are shown by
npm owner ls xmldom
NVD description
xmldom is a pure JavaScript W3C standard-based (XML DOM Level 2 Core) DOMParser and XMLSerializer module. xmldom versions 0.4.0 and older do not correctly preserve system identifiers, FPIs or namespaces when repeatedly parsing and serializing maliciously crafted documents. This may lead to unexpected syntactic changes during XML processing in some downstream applications. This is fixed in version 0.5.0. As a workaround downstream applications can validate the input and reject the maliciously crafted documents.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free