| Package | Affected versions | Patched versions |
|---|---|---|
| io.netty:netty | all versions | |
| io.netty:netty-codec-http2 | ≥ 4.0.0, < 4.1.61.Final | 4.1.61.Final |
| org.jboss.netty:netty | all versions | |
| netty | < 4.1.61 | 4.1.61 |
| banking corporate lending process management | = 14.2.0= 14.3.0= 14.5.0 | |
| banking credit facilities process management | = 14.2.0= 14.3.0= 14.5.0 | |
| banking trade finance process management | = 14.2.0= 14.3.0= 14.5.0 | |
| coherence | = 12.2.1.4.0= 14.1.1.0.0 | |
| communications brm - elastic charging engine | = 12.0.0.3 | |
| communications cloud native core console | = 1.7.0 | |
| communications cloud native core policy | = 1.14.0 | |
| communications design studio | = 7.4.2.0.0 | |
| communications messaging server | = 8.1 | |
| helidon | = 1.4.10= 2.4.0 | |
| jd edwards enterpriseone tools | < 9.2.6.3 | 9.2.6.3 |
| nosql database | < 21.1.12 | 21.1.12 |
| primavera gateway | ≥ 17.12.0, ≤ 17.12.11≥ 18.8.0, ≤ 18.8.11≥ 19.12.0, ≤ 19.12.10 | |
| quarkus | ≤ 1.13.7 |
The content-length header is not correctly validated if the request only use a single Http2HeaderFrame with the endStream set to to true. This could lead to request smuggling if the request is proxied to a remote peer and translated to HTTP/1.1
This is a followup of https://github.com/netty/netty/security/advisories/GHSA-wm47-8v5p-wjpj which did miss to fix this one case.
This was fixed as part of 4.1.61.Final
Validation can be done by the user before proxy the request by validating the header.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free