| Package | Affected versions | Patched versions |
|---|---|---|
| netmask | ≤ 1.0.6 | |
| netmask | < 1.1.0< 2.0.1 | 1.1.02.0.1 |
Improper input validation of octal strings in netmask npm package v1.0.6 and below allows unauthenticated remote attackers to perform indeterminate SSRF, RFI, and LFI attacks on many of the dependent packages. A remote unauthenticated attacker can bypass packages relying on netmask to filter IPs and reach critical VPN or LAN hosts.
:exclamation: NOTE: The fix for this issue was incomplete. A subsequent fix was made in version 2.0.1 which was assigned CVE-2021-29418 / GHSA-pch5-whg9-qr2r. For complete protection from this vulnerability an upgrade to version 2.0.1 or later is recommended.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free