| Package | Affected versions | Patched versions |
|---|---|---|
| trestle-auth | ≥ 0.4.0, < 0.4.2 | 0.4.2 |
| trestle-auth | = 0.4.0= 0.4.1 |
A vulnerability in trestle-auth versions 0.4.0 and 0.4.1 allows an attacker to create a form that will bypass Rails' built-in CSRF protection when submitted by a victim with a trestle-auth admin session. This potentially allows an attacker to alter protected data, including admin account credentials.
The vulnerability has been fixed in trestle-auth 0.4.2 released to RubyGems.
If you have any questions or comments about this advisory:
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free