요약
- CVE-2021-32702은(는) nextjs-auth0 (auth0), @auth0/nextjs-auth0에 영향을 주는 보통 (CVSS 6.1) 취약점입니다.
- 향후 30일 내 악용 확률(EPSS): 1.4%, 전체 취약점의 72.6%보다 높음.
- 조치: 1.4.2 이상으로 업데이트하세요.
Description
Overview
Versions before and including 1.4.1 are vulnerable to reflected XSS. An attacker can execute arbitrary code by providing an XSS payload in the error query parameter which is then processed by the callback handler as an error message.
Am I affected?
You are affected by this vulnerability if you are using @auth0/nextjs-auth0 version 1.4.1 or lower unless you are using custom error handling that does not return the error message in an HTML response.
How to fix that?
Upgrade to version 1.4.2.
Will this update impact my users?
The fix adds basic HTML escaping to the error message and it should not impact your users.
Credit
https://github.com/inian
https://github.com/git-ishanpatel
NVD description
The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. Versions before and including `1.4.1` are vulnerable to reflected XSS. An attacker can execute arbitrary code by providing an XSS payload in the `error` query parameter which is then processed by the callback handler as an error message. You are affected by this vulnerability if you are using `@auth0/nextjs-auth0` version `1.4.1` or lower **unless** you are using custom error handling that does not return the error message in an HTML response. Upgrade to version `1.4.1` to resolve. The fix adds basic HTML escaping to the error message and it should not impact your users.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free