요약
- CVE-2021-39187은(는) parse-server (parseplatform), parse-server에 영향을 주는 높음 (CVSS 7.5) 취약점입니다.
- 향후 30일 내 악용 확률(EPSS): 1.8%, 전체 취약점의 78.7%보다 높음.
- 조치: 4.10.3 이상으로 업데이트하세요.
Description
Impact
Parse Server crashes when if a query request contains an invalid value for the explain option. This is due to a bug in the MongoDB Node.js driver which throws an exception that Parse Server cannot catch.
Patches
Upgrade to Parse Server 4.10.3
NVD description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to version 4.10.3, Parse Server crashes when if a query request contains an invalid value for the `explain` option. This is due to a bug in the MongoDB Node.js driver which throws an exception that Parse Server cannot catch. There is a patch for this issue in version 4.10.3. No workarounds aside from upgrading are known to exist.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free