요약
- CVE-2021-41121은(는) vyper, vyper (vyperlang)에 영향을 주는 높음 (CVSS 8.8) 취약점입니다.
- 향후 30일 내 악용 확률(EPSS): 1.1%, 전체 취약점의 65.0%보다 높음.
- 조치: 0.3.0 이상으로 업데이트하세요.
| Package | Affected versions | Patched versions |
|---|
| vyper PyPI | < 0.3.0
| 0.3.0
|
| vyper | < 0.3.0
| 0.3.0
|
Description
Impact
When performing a function call inside a literal struct, there is a memory corruption issue that occurs because of an incorrect pointer to the the top of the stack.
Patches
0.3.0 / #2447
NVD description
Vyper is a Pythonic Smart Contract Language for the EVM. In affected versions when performing a function call inside a literal struct, there is a memory corruption issue that occurs because of an incorrect pointer to the the top of the stack. This issue has been resolved in version 0.3.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free