요약
- CVE-2021-41122은(는) vyper, vyper (vyperlang)에 영향을 주는 보통 (CVSS 4.3) 취약점입니다.
- 향후 30일 내 악용 확률(EPSS): 0.80%, 전체 취약점의 56.7%보다 높음.
- 조치: 0.3.0 이상으로 업데이트하세요.
| Package | Affected versions | Patched versions |
|---|
| vyper PyPI | < 0.3.0
| 0.3.0
|
| vyper | < 0.3.0
| 0.3.0
|
Description
Impact
The following code does not properly validate that its input is in bounds.
@external
def foo(x: decimal) -> decimal:
return x
Patches
0.3.0 / #2447
Workarounds
Don't use decimal args
NVD description
Vyper is a Pythonic Smart Contract Language for the EVM. In affected versions external functions did not properly validate the bounds of decimal arguments. The can lead to logic errors. This issue has been resolved in version 0.3.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free