요약
- CVE-2021-4231은(는) angular (angular), angularjs (angularjs), @angular/core에 영향을 주는 보통 (CVSS 5.4) 취약점입니다.
- 향후 30일 내 악용 확률(EPSS): 1.2%, 전체 취약점의 67.7%보다 높음.
- 조치: 11.0.5, 11.1.0-next.3, 10.2.5 이상으로 업데이트하세요.
| Package | Affected versions | Patched versions |
|---|
| angular | = 11.1.0
| No fix yet |
| angularjs | < 11.0.5
| 11.0.5
|
| @angular/core npm | ≥ 11.0.0, < 11.0.5≥ 11.1.0-next.0, < 11.1.0-next.3< 10.2.5
| 11.0.511.1.0-next.310.2.5
|
Description
A vulnerability was found in Angular up to 11.0.4/11.1.0-next.2. It has been classified as problematic. Affected is the handling of comments. The manipulation leads to cross site scripting. It is possible to launch the attack remotely but it might require an authentication first. Upgrading to version 10.2.5, 11.0.5 or 11.1.0-next.3 is advised to to address this issue.
NVD description
A vulnerability was found in Angular up to 11.0.4/11.1.0-next.2. It has been classified as problematic. Affected is the handling of comments. The manipulation leads to cross site scripting. It is possible to launch the attack remotely but it might require an authentication first. Upgrading to version 11.0.5 and 11.1.0-next.3 is able to address this issue. The name of the patch is ba8da742e3b243e8f43d4c63aa842b44e14f2b09. It is recommended to upgrade the affected component.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free