요약
- CVE-2021-43861은(는) mermaid (mermaid project), mermaid에 영향을 주는 보통 (CVSS 5.4) 취약점입니다.
- 향후 30일 내 악용 확률(EPSS): 0.94%, 전체 취약점의 61.0%보다 높음.
- 조치: 8.13.8 이상으로 업데이트하세요.
| Package | Affected versions | Patched versions |
|---|
| mermaid | < 8.13.8
| 8.13.8
|
| mermaid npm | < 8.13.8
| 8.13.8
|
Description
Impact
Malicious diagrams can contain javascript code that can be run at diagram readers machines.
Patches
The users should upgrade to version 8.13.8
Workarounds
You need to upgrade in order to avoid this issue.
NVD description
Mermaid is a Javascript based diagramming and charting tool that uses Markdown-inspired text definitions and a renderer to create and modify complex diagrams. Prior to version 8.13.8, malicious diagrams can run javascript code at diagram readers' machines. Users should upgrade to version 8.13.8 to receive a patch. There are no known workarounds aside from upgrading.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free