요약
- CVE-2022-21647은(는) codeigniter4/framework, codeigniter (codeigniter)에 영향을 주는 심각 (CVSS 9.8) 취약점입니다.
- 향후 30일 내 악용 확률(EPSS): 37.7%, 전체 취약점의 98.5%보다 높음.
- 조치: 4.1.6 이상으로 업데이트하세요.
Description
Impact
Deserialization of Untrusted Data was found in the old() function in CodeIgniter4.
Remote attackers may inject auto-loadable arbitrary objects with this vulnerability,
and possibly execute existing PHP code on the server.
We are aware of a working exploit, which can lead to SQL injection.
Patches
Upgrade to v4.1.6 or later.
Workarounds
Do not use:
old() and form_helper
RedirectResponse::withInput() and redirect()->withInput()
References
For more information
If you have any questions or comments about this advisory:
NVD description
CodeIgniter is an open source PHP full-stack web framework. Deserialization of Untrusted Data was found in the `old()` function in CodeIgniter4. Remote attackers may inject auto-loadable arbitrary objects with this vulnerability, and possibly execute existing PHP code on the server. We are aware of a working exploit, which can lead to SQL injection. Users are advised to upgrade to v4.1.6 or later. Users unable to upgrade as advised to not use the `old()` function and form_helper nor `RedirectResponse::withInput()` and `redirect()->withInput()`.
codeigniter4/framework의 다른 취약점
모두 보기 →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free