| Package | Affected versions | Patched versions |
|---|---|---|
| loofah | < 2.19.1 | 2.19.1 |
| loofah | < 2.19.1 | 2.19.1 |
Loofah < 2.19.1 contains an inefficient regular expression that is susceptible to excessive backtracking when attempting to sanitize certain SVG attributes. This may lead to a denial of service through CPU resource consumption.
Upgrade to Loofah >= 2.19.1.
The Loofah maintainers have evaluated this as High Severity 7.5 (CVSS3.1).
This vulnerability was responsibly reported by @ooooooo-q (https://github.com/ooooooo-q).
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free