요약
- CVE-2022-23915은(는) weblate, weblate (weblate)에 영향을 주는 높음 (CVSS 8.8) 취약점입니다.
- 향후 30일 내 악용 확률(EPSS): 3.1%, 전체 취약점의 87.8%보다 높음.
- 조치: 4.11.1 이상으로 업데이트하세요.
| Package | Affected versions | Patched versions |
|---|
| weblate PyPI | < 4.11.1
| 4.11.1
|
| weblate | < 4.11.1
| 4.11.1
|
Description
Impact
Weblate didn't correctly sanitize some arguments passed to Git and Mercurial, which allowed changing their behavior in an unintended way.
Patches
The issues were fixed in the 4.11.1 release. The following commits are addressing it:
- 35d59f1f040541c358cece0a8d4a63183ca919b8
- d83672a3e7415da1490334e2c9431e5da1966842
Workarounds
Instances in which untrusted users cannot create new components are not affected.
References
For more information
If you have any questions or comments about this advisory:
NVD description
The package weblate from 0 and before 4.11.1 are vulnerable to Remote Code Execution (RCE) via argument injection when using git or mercurial repositories. Authenticated users, can change the behavior of the application in an unintended way, leading to command execution.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free