요약
- CVE-2022-24709은(는) awsui/components-react (amazon), @awsui/components-react에 영향을 주는 보통 (CVSS 6.1) 취약점입니다.
- 향후 30일 내 악용 확률(EPSS): 0.69%, 전체 취약점의 52.9%보다 높음.
- 조치: 3.0.367 이상으로 업데이트하세요.
Description
Impact
Components could potentially allow cross-site scripting (XSS) in certain circumstances. These components could render content without adequate neutralization.
Patches
Fixed in 3.0.367.
NVD description
@awsui/components-react is the main AWS UI package which contains React components, with TypeScript definitions designed for user interface development. Multiple components in versions before 3.0.367 have been found to not properly neutralize user input and may allow for javascript injection. Users are advised to upgrade to version 3.0.367 or later. There are no known workarounds for this issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free