| Package | Affected versions | Patched versions |
|---|---|---|
| drupal/core | ≥ 8.0.0, < 9.2.16≥ 9.3.0, < 9.3.9 | 9.2.169.3.9 |
| guzzlehttp/psr7 | ≥ 2.0.0, < 2.1.1< 1.8.4 | 2.1.11.8.4 |
| drupal | ≥ 8.0.0, < 9.2.16≥ 9.3.0, < 9.3.9 | 9.2.169.3.9 |
| psr-7 | ≥ 2.0.0, < 2.1.1< 1.8.4 | 2.1.11.8.4 |
Improper header parsing. An attacker could sneak in a carriage return character (\r) and pass untrusted values in both the header names and values.
The issue is patched in 1.8.4 and 2.1.1.
There are no known workarounds.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free