요약
- CVE-2022-35944은(는) october/system, october (octobercms)에 영향을 주는 높음 (CVSS 7.2) 취약점입니다.
- 향후 30일 내 악용 확률(EPSS): 1.1%, 전체 취약점의 64.3%보다 높음.
- 조치: 2.2.34, 3.0.66 이상으로 업데이트하세요.
| Package | Affected versions | Patched versions |
|---|
| october/system Packagist | ≥ 2.0.0, < 2.2.34≥ 3.0.0, < 3.0.66
| 2.2.343.0.66
|
| october | ≥ 3.0.00, < 3.0.66< 2.2.34
| 3.0.662.2.34
|
Description
Impact
This vulnerability only affects installations that rely on the safe mode restriction, commonly used when providing public access to the admin panel. Assuming an attacker has access to the admin panel and permission to open the "Editor" section, they can bypass the Safe Mode (cms.safe_mode) restriction to introduce new PHP code in a CMS template using a specially crafted request.
Patches
The issue has been patched in v2.2.34 and v3.0.66
References
Credits to:
For more information
If you have any questions or comments about this advisory:
NVD description
October is a self-hosted Content Management System (CMS) platform based on the Laravel PHP Framework. This vulnerability only affects installations that rely on the safe mode restriction, commonly used when providing public access to the admin panel. Assuming an attacker has access to the admin panel and permission to open the "Editor" section, they can bypass the Safe Mode (`cms.safe_mode`) restriction to introduce new PHP code in a CMS template using a specially crafted request. The issue has been patched in versions 2.2.34 and 3.0.66.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free