요약
- CVE-2022-36031은(는) directus (monospace), directus에 영향을 주는 보통 (CVSS 6.5) 취약점입니다.
- 향후 30일 내 악용 확률(EPSS): 0.97%, 전체 취약점의 61.9%보다 높음.
- 조치: 9.15.0 이상으로 업데이트하세요.
| Package | Affected versions | Patched versions |
|---|
| directus | < 9.15.0
| 9.15.0
|
| directus npm | < 9.15.0
| 9.15.0
|
Description
The Directus process can be aborted by having an authorized user update the filename_disk value to a folder and accessing that file through the /assets endpoint.
The vulnerability is patched and released in v9.15.0.
You can prevent this problem by making sure no (untrusted) non-admin users have permissions to update the filename_disk field on directus_files.
For more information
If you have any questions or comments about this advisory:
Credits
This vulnerability was first discovered and reported by Witold Gorecki.
NVD description
Directus is a free and open-source data platform for headless content management. The Directus process can be aborted by having an authorized user update the `filename_disk` value to a folder and accessing that file through the `/assets` endpoint. This vulnerability has been patched and release v9.15.0 contains the fix. Users are advised to upgrade. Users unable to upgrade may prevent this problem by making sure no (untrusted) non-admin users have permissions to update the `filename_disk` field on `directus_files`.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free