| Package | Affected versions | Patched versions |
|---|---|---|
| nextcloud enterprise server | ≥ 23.0.0, < 23.0.7≥ 24.0.0, < 24.0.3< 22.2.11 | 23.0.724.0.322.2.11 |
| nextcloud server | ≥ 24.0.0, < 24.0.3< 23.0.7 | 24.0.323.0.7 |
Nextcloud server is an open source personal cloud product. Affected versions of this package are vulnerable to Information Exposure which fails to strip the Authorization header on HTTP downgrade. This can lead to account access exposure and compromise. It is recommended that the Nextcloud Server is upgraded to 23.0.7 or 24.0.3. It is recommended that the Nextcloud Enterprise Server is upgraded to 22.2.11, 23.0.7 or 24.0.3. There are no known workarounds for this issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free