요약
- CVE-2022-39383은(는) github.com/oam-dev/kubevela, kubevela (linuxfoundation)에 영향을 주는 보통 (CVSS 6.5) 취약점입니다.
- 향후 30일 내 악용 확률(EPSS): 0.42%, 전체 취약점의 36.7%보다 높음.
- 조치: 1.6.1, 1.6.2, 1.5.8, 1.5.9 이상으로 업데이트하세요.
| Package | Affected versions | Patched versions |
|---|
| github.com/oam-dev/kubevela Go | ≥ 1.6.0, < 1.6.1≥ 1.6.0-alpha.1, < 1.6.2< 1.5.8< 1.5.9
| 1.6.11.6.21.5.81.5.9
|
| kubevela | ≥ 1.6.0, < 1.6.2< 1.5.9
| 1.6.21.5.9
|
Description
Impact
Users using the VelaUX APIServer could be affected by this vulnerability.
When using Helm Chart as the component delivery method, the request address of the warehouse is not restricted, and there is a blind SSRF vulnerability.
This issue is patched in 1.5.9 and 1.6.2.
References
Fix by: #5000
For more information
If you have any questions or comments about this advisory:
NVD description
KubeVela is an open source application delivery platform. Users using the VelaUX APIServer could be affected by this vulnerability. When using Helm Chart as the component delivery method, the request address of the warehouse is not restricted, and there is a blind SSRF vulnerability. Users who're using v1.6, please update the v1.6.1. Users who're using v1.5, please update the v1.5.8. There are no known workarounds for this issue.
github.com/oam-dev/kubevela의 다른 취약점
모두 보기 →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free