| Package | Affected versions | Patched versions |
|---|---|---|
| github.com/rancher/wrangler | ≥ 0.8.0, < 0.8.5-security1≥ 0.8.6, < 0.8.11≥ 1.0.0, < 1.0.1< 0.7.4-security1 | 0.8.5-security10.8.111.0.10.7.4-security1 |
| wrangler | = 1.0.0≥ 0.8.0, < 0.8.5< 0.7.4 | 0.8.50.7.4 |
A denial of services (DoS) vulnerability was discovered in Wrangler Git package affecting versions up to and including v1.0.0.
Specially crafted Git credentials can result in a denial of service (DoS) attack on an application that uses Wrangler due to the exhaustion of the available memory and CPU resources. This is caused by a lack of input validation of Git credentials before they are used, which may lead to a denial of service in some cases. This issue can be triggered when accessing both private and public Git repositories.
A workaround is to sanitize input passed to the Git package to remove potential unsafe and ambiguous characters. Otherwise, the best course of action is to update to a patched Wrangler version.
Patched versions include v1.0.1 and later and the backported tags - v0.7.4-security1, v0.8.5-security1 and v0.8.11.
If you have any questions or comments about this advisory:
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free