| Package | Affected versions | Patched versions |
|---|---|---|
| org.apache.xmlgraphics:batik-bridge | ≥ 1.0, < 1.17 | 1.17 |
| org.apache.xmlgraphics:batik-svgrasterizer | ≥ 1.0, < 1.17 | 1.17 |
| org.apache.xmlgraphics:batik-transcoder | ≥ 1.0, < 1.17 | 1.17 |
| xml graphics batik | ≥ 1.0, ≤ 1.16 |
Server-Side Request Forgery (SSRF) vulnerability in Apache Software Foundation Apache XML Graphics Batik.This issue affects Apache XML Graphics Batik: 1.16.
On version 1.16, a malicious SVG could trigger loading external resources by default, causing resource consumption or in some cases even information disclosure. Users are recommended to upgrade to version 1.17 or later.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free